"rails new" command always takes me to help

Couldn't find a solution anywhere so I'm posting here.

I'm running rvm and Ruby 1.9.2-p180 [x86_64]. I installed rails 3.0.7
via 'gem install rails' and was running 'rails new' at command line
without issue (Mac OS X, 10.6.6) for some time now to create my

Now, 'rails new myapp' doesn't work: I keep getting the help output
for some reason instead (the same output as if you ran 'rails -h'). I
tried uninstalling and uninstalling rails via 'gem uninstall' but
still no fix.

This was all running before. The only thing I did since then was
install jruby...could that have mucked up with some settings?

Unfortunately I can't trace it when I run 'rails new' so I have no
idea why it isn't working.

Any thoughts?

What does

rails -v

tell you ?

Also, try running

rails new app1 --ruby /path/to/your/matz_ruby

Also, try to create different gemsets with rvm and run with different
version of rails/ruby. Does it help ?

I came across the same issue couple of days ago and it seemed to be a
problem with some of the installed gems, I had done gem cleanup and
removed some dependent gems. A fresh install on all the gems and rails
itself helped me.



ianha wrote in post #998925:

Make sure that you are not inside an existing rails app when you do
rails new. If you are then it will not allow new and displays the
commands that are valid (generate, console and so on).


Thanks everyone, running 'gem cleanup' seems to have done the trick'!