Rails default app not loading

The most probably reason is that the newest version of Rails is 2.0,
this tutorial is written for 1.2. Outstanding tutorials are yet to
come for 2.0 (AFAIK).

To play with version 1.2, do this from the command line (NOTE:
uninstalls rails 2 and installs rails 1.2)

  gem uninstall rails
  gem install rails -v 1.2.6

If it still doesn't work, or you want to play with 2.0 anyway: Run
the server (script/server). After it starts, copy and paste what it
prints out to the command line into this thread. That may tell us if
there's an error with the booting process -- which is what I suspect.