Rails 6 with postgres and active admin on aws lambda

hi there, i’m at my wit’s end here… i’m using ruby 2.7 with rails 6 and postgres on aws lambda. after copying some *.so files around it was actually working… until i added activeadmin and especially ransack (added that through git) now i get the following error and i can’t for the live of me figure out what to do about it… any help would be greatly appreciated… oh… also of note: i’m using lamby so here goes: { “errorMessage”: “There was an error while trying to load the gem ‘ransack’.\nGem Load Error is: Unsupported adapter\nBacktrace for gem load error is:\n/var/task/vendor/bundle/ruby/2.7.0/bundler/gems/ransack-c9cc20de9e0f/lib/ransack/adapters.rb:14:in instantiate_object_mapper'\n/var/task/vendor/bundle/ruby/2.7.0/bundler/gems/ransack-c9cc20de9e0f/lib/ransack/adapters.rb:5:in object_mapper’\n/var/task/vendor/bundle/ruby/2.7.0/bundler/gems/ransack-c9cc20de9e0f/lib/ransack.rb:6:in <top (required)>'\n/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:74:in require’\n/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:74:in block (2 levels) in require'\n/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:69:in each’\n/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:69:in block in require'\n/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:58:in each’\n/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:58:in require'\n/var/runtime/gems/bundler-2.1.4/lib/bundler.rb:174:in require’\n/var/task/config/application.rb:7:in <top (required)>'\n/var/task/app.rb:6:in require_relative’\n/var/task/app.rb:6:in <top (required)>'\n/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:72:in require’\n/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:72:in require'\n/var/runtime/lib/runtime.rb:68:in '\nBundler Error Backtrace:\n”, “errorType”: “InitBundler::GemRequireError”, “stackTrace”: [ “/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:77:in rescue in block (2 levels) in require'", "/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:73:in block (2 levels) in require’”, “/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:69:in each'", "/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:69:in block in require’”, “/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:58:in each'", "/var/runtime/gems/bundler-2.1.4/lib/bundler/runtime.rb:58:in require’”, “/var/runtime/gems/bundler-2.1.4/lib/bundler.rb:174:in require'", "/var/task/config/application.rb:7:in <top (required)>’”, “/var/task/app.rb:6:in require_relative'", "/var/task/app.rb:6:in <top (required)>’”, “/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:72:in require'", "/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:72:in require’” ] }