Rails 2.3.4 -> 2.3.14: broken api compatibility?

Hi *,

I cannot find any active bug tracker, so I want to share my todays
experience here...

Concerning this commit:


I updated my rails app today and discovered, that this commit might
have broken some compatibility. I used something like this:

collection = <Model>.scoped

This does not work anymore, I have to add ({}) - so i think it should

def scoped(scope={}, &block)

instead of

def scoped(scope, &block)

What do you think?

It does seem like you’ve found an unintentional breakage introduced in the 2-3 stream, however 2.3 is now only receiving security fixes so this won’t be fixed. You’ll have to change your code to work around this, or upgrade to 3.0 or 3.1 to avoid it entirely.