rails 2.0.2 on windows problems

I'm having trouble with running mongrel once I updated rails to 2.0
from 1.2.5. This is the list of my installed gems

*** LOCAL GEMS ***

actionmailer (2.0.2, 2.0.1, 1.3.3)
actionpack (2.0.2, 2.0.1, 1.13.3)
actionwebservice (1.2.6, 1.2.3)
activerecord (2.0.2, 2.0.1, 1.15.3)
activeresource (2.0.2, 2.0.1)
activesupport (2.0.2, 2.0.1, 1.4.2)
activewarehouse (0.3.0, 0.2.0)

ar-extensions (0.7.0)
ar_fixtures (0.0.4)
builder (2.1.2)
capistrano (2.1.0, 1.4.1)
cgi_multipart_eof_fix (2.5.0, 2.1)
color-tools (1.3.0)
daemons (1.0.9, 1.0.6, 0.4.2)
deprec (1.9.1)

gem_plugin (0.2.3, 0.2.2)
mongrel (1.1.2, 1.1.1, 1.0.5, 1.0.1)
mongrel_cluster (1.0.5, 1.0.2)
mongrel_service (0.3.3, 0.3.1)
needle (1.3.0)
net-sftp (1.1.0)
net-ssh (1.1.2)
nitro (0.41.0)
og (0.41.0)
paginator (1.1.0)
parseexcel (0.5.2)
pdf-writer (1.1.7, 1.1.3)
rails (2.0.2, 2.0.1, 1.2.3)
rails_creator (0.6.2)
rails_sql_views (0.6.1, 0.5.1)
rake (0.8.0, 0.7.3, 0.7.2)
rbehave (0.3.0)
rcov (0.8.1.2.0, 0.8.0.2)
RedCloth (3.0.4)
rspec (1.1.1, 1.0.8)
ruby-breakpoint (0.5.1, 0.5.0)
ruby-debug-base (0.9.3)
ruby-debug-ide (0.1.9)
ruby-snarl (0.0.8)
rubyclr (0.5.2)
rubyforge (0.4.4, 0.4.2)
rubygems-update (1.0.1, 0.9.5)

win32-service (0.5.2)
win32-sound (0.4.1, 0.4.0)
win32console (1.0.8)
windows-pr (0.7.4, 0.6.2)
zentest (3.5.0)
ZenTest (3.7.0, 3.6.1)
This is the error I get:
D:\Brian\code\Payroll>ruby script/server
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_re
quire': no such file to load -- c:/ruby/lib/ruby/gems/1.8/gems/
mongrel_service-0
.3.1-x86-mswin32/lib/mongrel_service/init.rb (MissingSourceFile)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `re
quire'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/
active_suppo
rt/dependencies.rb:496:in `require'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/
active_suppo
rt/dependencies.rb:342:in `new_constants_in'
        from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.0.1/lib/
active_suppo
rt/dependencies.rb:496:in `require'
        from c:/ruby/lib/ruby/gems/1.8/gems/gem_plugin-0.2.3/lib/
gem_plugin.rb:1
34:in `load'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:
163:in `eac
h'

When I try to install mongrel_service-0.3.1 I get this error:

C:\ruby\lib\ruby\gems\1.8\cache>gem install mongrel_service-0.3.1-
mswin32.gem
ERROR: While executing gem ... (NoMethodError)
    undefined method `include?' for nil:NilClass

C:\ruby\lib\ruby\gems\1.8\cache>
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:
163:in `eac
h'
        from c:/ruby/lib/ruby/gems/1.8/gems/gem_plugin-0.2.3/lib/
gem_plugin.rb:1
12:in `load'
         ... 11 levels...
        from c:/ruby/lib/ruby/gems/1.8/gems/rails-2.0.1/lib/commands/
server.rb:3
9
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `ge
m_original_require'
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `re
quire'
        from script/server:3
Anybody had similar problems??

Loads of people, it's to do with rubygems 0.9.5+ and the changes made
to accommodate ruby 1.9. Precompiled gems like mongrel/win32 are
having some problems with this due to the folder naming conventions.
Either use webrick in dev mode (assume your're not trying to run
production site on windows) or i think you can reinstall gems 0.9.4
from scratch, but i haven't tried.

Try starting over. Rename c:\ruby to c:\ruby2 and start from scratch.

I just did a fresh install on Windows today and everything works again. A few gems were updated within the last few days. The only issue was a problem with mongrel_service and the current gem of win32_service. I posted about that here, along with instructions for a fresh install:

http://www.napcsweb.com/blog/2008/01/01/mongrel_service-broken-on-windows-again/

-Brian Hogan

Yes, what others have said. Make sure you have RubyGems 1.0.x and you
should be fine.

You could also try using InstantRails on RubyForge, it has everything
already done for you.

-Rob Bazinet