Problems connecting Postgres-pr with rails 2.3.5 on windows 7

I changed my laptop for a one with windows 7. I installed rails 2.3.5,
postgres-pr 0.6.3, mongrel 1.1.5 and copied my app that was previously
on a win xp PC. When I launched my server and connected to my app, I had
the following error :

Status: 500 Internal Server Error
  uninitialized constant PostgresPR::Connection::UNIXSocket
    C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:105:in
`const_missing'
    C:/Ruby187/lib/ruby/gems/1.8/gems/postgres-pr-0.6.3/lib/postgres-pr/connection.rb:167:in
`establish_connection'

I resolved this problem by looking at my database.yml file. The
development section was like that :

development:
  adapter: postgresql
  encoding: UTF8
  database: my_database_development
  pool: 5
  username: xxxxx
  password: xxxxx

  # Connect on a TCP socket. Omitted by default since the client uses a
  # domain socket that doesn't need configuration. Windows does not have
  # domain sockets, so uncomment these lines.
  #host: localhost
  #port: 5432

I just uncommented the last 2 lines (as is recommended...) :

  host: localhost
  port: 5432

and it worked just fine. It worked fine on the win xp machine with these
lines commented, though.

Hope this will be of some help if you've ran into this kind of problem.