Problem with starting Rails. Please help.

Dear All:

I am new to Rails. This is my first day of using Rails.I have already
installed Ruby and Rails on my computer.
But in new application- script folder 'server' script is not getting
created.
In short I am not able to run- ruby script/server.
Please help me or suggest another way to set up Rails on Windows.

I am using Windows XP.
Thanks in advance.

You didn’t specify which Rails version you are using.

Looks like you are on Rails 3, in that case, on of the following two should work:

rails server (shorthand is rails s)

or

ruby script/rails server

You may also want to read up Rails guides, which is very good if you are a beginner and will address these basic issues - http://guides.rubyonrails.org/getting_started.html

Thanks for your prompt replies. I am using Rails 3.0.9 version. I used ‘ruby script/rails server’ command.
But I am getting following error pop-up while running this command.

The procedure entry point sqlite3_column_database_name could not be located in the dynamic link library sqlite3.dll

Please suggest some solution.

Thanks,

Amit

Make sure that you have sqlite3 installed on your machine and sqlite3 gem is also installed.

If you don’t have sqlite3 installed on windows, then you can grab sqlite3.dll from here http://www.sqlite.org/download.html and copy it to either your ruby bin directory or windows’ system32 directory. Open up a new console and run the server again.

As an aside, I have found that RailsInstaller works pretty well for all this default setup on windows. You may want to try it out - http://railsinstaller.org/

Thank you very much Chirag. It worked. Could you please tell me how to replace SQLite with MySQL?

Two ways:

  1. You can specify that while creating your project - rails new myapp -d mysql

  2. Manually modify your database.yml file to use mysql and update your Gemfile to use mysql gem

sample config for database.yml, you will need similar entries for production and test databases

development:

adapter: mysql

encoding: utf8

reconnect: false

database: myapp_development

pool: 5

username: root

password: password

host: localhost

in your Gemfile, add:

gem ‘mysql’

Hi Chirag,

Thanks for your great help. I have one more question. It may be a silly one. You suggested that

in your Gemfile, add:

gem ‘mysql’

I am not clear with the Gemfile. Please tell me where to find it.

It will be in your applications root folder. Along with the files like README, Rakefile, etc

Hi Chirag,
I am still getting error while starting the rails.
<-[31mCould not find gem ‘mysql112 (~> 0.2.6)’ in any of the gem sources listed in your Gemfile. <-[0m
Please help on this, I found the gem file and added gem ‘mysql’ in to it but it still shows error. please help on this.

Thanks,
Amit

looks like you have wrong entry in your Gemfile.

Can you attach or paste contents of your Gemfile?

Chirag
http://sumeruonrails.com

Hi,

Gem file is as follows:

source ‘http://rubygems.org

gem ‘rails’, ‘3.0.9’

Bundle edge Rails instead:

gem ‘rails’, :git => ‘git://github.com/rails/rails.git

gem ‘mysql2’, ‘~> 0.2.6’

Use unicorn as the web server

gem ‘unicorn’

Deploy with Capistrano

gem ‘capistrano’

To use debugger (ruby-debug for Ruby 1.8.7+, ruby-debug19 for Ruby 1.9.2+)

gem ‘ruby-debug’

gem ‘ruby-debug19’, :require => ‘ruby-debug’

Bundle the extra gems:

gem ‘bj’

gem ‘nokogiri’

gem ‘sqlite3-ruby’, :require => ‘sqlite3’

gem ‘aws-s3’, :require => ‘aws/s3’

Bundle gems for the local environment. Make sure to

put test-only gems in this group so their generators

and rake tasks are available in development mode:

group :development, :test do

gem ‘webrat’

end

mysql2 won’t install on windows, use mysql gem instead.

So, change this line

gem ‘mysql2’, ‘~> 0.2.6’

to

gem ‘mysql’

and in your config/database.yml file, change the adapter from mysql2 to mysql for all 3 databases.

Chirag
http://sumeruonrails.com

Hi Chirag,

It worked !!! Thank you very very much. :slight_smile:

Thanks,
-Amit.