Problem with deployment of rails application using passenger and apache (Very Important)

Hello All,

I have been facing a weird problem since long and sometimes the things
worked for me on one or the other server.

Again, I have build a new server and facing same problem. Could anyone
help me in finding the cause??

I have passenger modules loaded inside apache conf file and
DocumentRoot set to point to public directory. This Document Root
works for static pages.

When I am going to browser and hitting the mydomain.com , I get the
directory listing of public directory (similar to what we get using
FTP links). I have been able to setup rails previously multiple times
using mongrel but don't know why this problem is coming.

This problem came before also when I tried setting up the apache conf
pointing to /var/www/html and had stored a symbolic link of public
directory inside /var/www/html. At that point also it used to display
the directory structure instead of the web page.

The problem to me seems to be something that the rails application is
not able to execute and display the web page. But exactly I don't know
the reason. I am not so much familiar with the apache configuration.

Thanks,

-S

Have you also set the

PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-2.x.x
PassengerRuby /usr/bin/ruby

sentences on Apachce conf?

Yes I have set the two appropriate configuration lines in apache. I
was wondering if I need to enable any specific apache module for this.

Solved :

Linux Fedora's security policy was blocking the Phusion from
initiation.

Thanks to others for reply