Not changes layouts

Hi, when i upload changes on layouts in production no show changes.

So I

* bundle exec rake tmp:clear RAILS_ENV=production
* bundle exec rake log:clear RAILS_ENV=production
* bundle exec rake assets:clean RAILS_ENV=production
* bundle exec rake assets:clobber RAILS_ENV=production
* bundle exec rake assets:precompile RAILS_ENV=production

and in enviroment/production.rb set

* config.serve_static_assets = true
* config.assets.enabled = true

but not changes...

manually delete all files in the /public/assets directory (you can leave the directory there, just make sure it’s empty) and rerun assets:precompile.

I tried and continued seeing the same thing, this is my site
www.miapoyoescolar.com. Delete the entire folder of my hosting and I
went up which in my local machine if it works, but I keep seeing the
construction template

What do you see in the log when you visit the link?

Colin

I, [2014-05-14T18:18:16.115869 #9178] INFO -- : Started GET "/" for
186.59.132.46 at 2014-05-14 18:18:16 -0300
I, [2014-05-14T18:18:16.117223 #9178] INFO -- : Processing by
WelcomesController#index as HTML
I, [2014-05-14T18:18:16.119276 #9178] INFO -- : Rendered
welcomes/index.html.erb within layouts/application (0.1ms)
I, [2014-05-14T18:18:16.130415 #9178] INFO -- : Completed 200 OK in
13ms (Views: 11.3ms | ActiveRecord: 0.0ms)
I, [2014-05-14T18:18:16.237590 #9178] INFO -- : Started GET
"/assets/jasny-bootstrap.min-17086ccabd2512085ad67c74faaa38fc.css" for
186.59.132.46 at 2014-05-14 18:18:16 -0300
I, [2014-05-14T18:18:16.308748 #9178] INFO -- : Started GET
"/assets/bootstrap.min-fa3ffbdc2bf8ca7a47baf421fcd20b8c.css" for
186.59.132.46 at 2014-05-14 18:18:16 -0300

. . .
. . . ( I put the dots here ... )
. . .

I, [2014-05-14T18:18:16.876181 #9178] INFO -- : Started GET
"/assets/functions-41bab4c922f6fbb94532e09950d41e9f.js" for
186.59.132.46 at 2014-05-14 18:18:16 -0300

wonder the site shows something that no longer exists ...

the log entries you’re giving us don’t match your site. for example, when I go to your link at look at the source code, there’s a link to the following file:

but if you look at the log you provided us, the key for that file begins with fa3ff. Exactly where is this log coming from? Is this the log in your local environment? Also, the IP addresses are different. The DNS record for www.miapoyoescolar.com points to the IP address 201.235.253.82 but your log entries show a different IP address that isn’t public.

I’m afraid that without knowledge of your hosting environment, it will be difficult to help you, but this issue appears to be a deployment issue.

One thing noticeably absent from this list: restarting the worker processes that are actually serving your application. The layout template is compiled when first used and not reloaded after that in production.

If you’re running on Passenger, touch tmp/restart.txt from your Rails root will cause the workers to restart. Check your server’s documentation for something similar if you’re not on Passenger.

On an unrelated note, you should seriously consider using source control if you aren’t already. “Uploading files” takes me back to the old days of FTPing PHP codez… :slight_smile:

–Matt Jones

One question, is there any difference in creating the web application on
the local machine and the hosting? Because I ran the "rails new
mi_proyect" command locally and then went up to hosting ALL files