Newbie trying to set up rails with MySQL

Hello --

Please pardon my newness -- I'm just getting started with rails, and
I'm having some difficulty getting it set up with MySQL.

I am able to get the basic ruby server running (script\server). When I
created a new page (using script/generate controller about index), I
am not able to navigate to the new page, and Ruby either crashes or
gives me an error:

/!\ FAILSAFE /!\ Tue Jun 15 13:53:08 -0700 2010
  Status: 500 Internal Server Error
  Access denied for user 'root'@'localhost' (using password: NO)

I have modified the database.yml file (full text of file pasted
below). I know the password is correct, as it is what I use to launch
mysql. When I enter 'show databases' into MySQL monitor, I see the two
databases I specified (emporium_development and emporium_test). The
MySQL service is running (I'm on Win7). I have tried both restarting
the MySQL service and restarting the ruby server. I created the
project with the command: 'rails emporium -d mysql' and prior to that,
I installed the mysql driver for rails using the command 'gem install
mysql'. I installed the 105.4 MB mysql from here:
http://dev.mysql.com/downloads/mysql/5.1.html#downloads, but I have
not installed anything else (outside of rails).

Thank you for any help you can offer!!
Sarah

database.yml:

# MySQL. Versions 4.1 and 5.0 are recommended.

Last time I checked (which is at least 6 months ago now), the RoR
mysql adapter and mysql 5.1 did not play well together on Vista/Win7.
You may want to try version 5.0 before anything else.

I did the same for XP, I installed 5.0

This link my give some additional help:
http://stackoverflow.com/questions/1557267/mysql-driver-for-rails-in-windows-7-x64

JRuby works without any problem (at least with XP) since is using the
Jdbc adapter, but probably you want to use C Ruby.

The problem is usually the dll and you could try this dll from
instantrails: http://instantrails.rubyforge.org/svn/trunk/InstantRails-win/InstantRails/mysql/bin/

As you know Ruby works better on Unix (Matz words) so if you can use
Ubuntu or a Mac. After many complaints, at work, I managed to get a
Mac and now I am really happy about my dev environment. If I where
still in Windows, probably now I would be using JRuby for sure.

Yep,
my problems was almost the same! And still not workable with mysql, I
don"t know why. Please let me know if you have useful answer!
Thnaks,
gezope