New to Ruby On Rails. Problems Installing Rails.

Hi Everyone,

  I am completely new to this thing and i have absolutely no clue about
Ruby and Rails/Gems anything. So i thought about starting off on this
learning path. I have got some tutorials and learning stuff with me. But
before that i thought of at least getting the software installed. I got
Ruby and Gems done properly but when i try to install Rails i get a
weird exception I dont know anything about Ruby so cant troubleshoot
myself.

C:\ruby\bin>gem install rails --include-dependencies
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: rails requires activesupport (=
2.3.4), activerecord (= 2.3.4), actionpack (= 2.3.4), actionmailer (=
2.3.4), acti
veresource (= 2.3.4)

My version are:
Ruby: ruby 1.9.3p0 (2011-10-30) [i386-mingw32]
Gem: 1.8.11.

P.S. - Does the registration question have to be so much into Ruby? I
had to Google for the answer and register! :slight_smile:

try
$gem update rails