Error while installing the rails gem

Salvador Sanjuan wrote:

Salvador Sanjuan wrote:

While trying to install the rails gem this is what happens:

C:\>gem install rails --include-dependencies
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: Error installing rails:
        actionpack requires rack (~> 1.0.0, runtime)

C:\>gem update rack
Updating installed gems
Nothing to update

As you see I previously installed the rack gem but it seems that
something is not working during the installation.

Any ideas?

Thanks

Checkign my previous error I have seen that while installing racks there
must be an error because is installing another gem, activesupport .

C:\>gem install rack
Successfully installed activesupport-2.3.3
1 gem installed
Installing ri documentation for activesupport-2.3.3...
Installing RDoc documentation for activesupport-2.3.3...

The problem as I though is with the installation of the rack gem. As the
remote installation I tried a local installation.

First I went to http://gems.rubyforge.org/ and downloaded the rack gem
to a folder I named Gems in My docuemnts

Second from the command shell in Windows I tried the installation again
but this time I told the gem to do it locally

C:\Documents and Settings\SSanjuan\Mis documentos\Gems>gem install rack
-l
Successfully installed rack-1.0.0
1 gem installed
Installing ri documentation for rack-1.0.0...
Installing RDoc documentation for rack-1.0.0...

Afterwards I could install rails without any problem