ERROR installing documentation while gem install rails (Win7 Rails 1.9.3)

Using Windows 7 Professional
Loaded Ruby v1.9.3p545 (2014-02-24) [i386-mingw32]

Installed dev kit (C:/Ruby193/lib/ruby/site_ruby/devkit.rb)

Tried to install rails at this point with “gem install rails”. Process died and received the following error while installing docs:

ERROR: While generating documentation for actionpack-4.1.1

… MESSAGE: Invalid argument - ./ActionDispatch/Routing/Mapper/Scoping/:

… RDOC args: --ri --op C:/Ruby193/lib/ruby/gems/1.9.1/doc/actionpack-4.1.1/ri lib --title actionpack-4.1.1 Documentation --quiet

I figure I can live without documentation, but this is a problem and I am wondering if anyone has resolved this issue?

Full install output:

C:\RubyDevKit>gem install rails

Temporarily enhancing PATH to include DevKit…

Building native extensions. This could take a while…

Fetching: thread_safe-0.3.3.gem (100%)

Fetching: tzinfo-1.1.0.gem (100%)

Fetching: minitest-5.3.3.gem (100%)

Fetching: activesupport-4.1.1.gem (100%)

Fetching: rack-1.5.2.gem (100%)

Fetching: rack-test-0.6.2.gem (100%)

Fetching: builder-3.2.2.gem (100%)

Fetching: erubis-2.7.0.gem (100%)

Fetching: actionview-4.1.1.gem (100%)

Fetching: actionpack-4.1.1.gem (100%)

Fetching: activemodel-4.1.1.gem (100%)

Fetching: arel-5.0.1.20140414130214.gem (100%)

Fetching: activerecord-4.1.1.gem (100%)

Fetching: mime-types-1.25.1.gem (100%)

Fetching: polyglot-0.3.4.gem (100%)

Fetching: treetop-1.4.15.gem (100%)

Fetching: mail-2.5.4.gem (100%)

Fetching: actionmailer-4.1.1.gem (100%)

Fetching: thor-0.19.1.gem (100%)

Fetching: railties-4.1.1.gem (100%)

Fetching: bundler-1.6.2.gem (100%)

Fetching: hike-1.2.3.gem (100%)

Fetching: multi_json-1.10.0.gem (100%)

Fetching: tilt-1.4.1.gem (100%)

Fetching: sprockets-2.12.1.gem (100%)

Fetching: sprockets-rails-2.1.3.gem (100%)

Fetching: rails-4.1.1.gem (100%)

Successfully installed json-1.8.1

Successfully installed thread_safe-0.3.3

Successfully installed tzinfo-1.1.0

Successfully installed minitest-5.3.3

Successfully installed activesupport-4.1.1

Successfully installed rack-1.5.2

Successfully installed rack-test-0.6.2

Successfully installed builder-3.2.2

Successfully installed erubis-2.7.0

Successfully installed actionview-4.1.1

Successfully installed actionpack-4.1.1

Successfully installed activemodel-4.1.1

Successfully installed arel-5.0.1.20140414130214

Successfully installed activerecord-4.1.1

Successfully installed mime-types-1.25.1

Successfully installed polyglot-0.3.4

Successfully installed treetop-1.4.15

Successfully installed mail-2.5.4

Successfully installed actionmailer-4.1.1

Successfully installed thor-0.19.1

Successfully installed railties-4.1.1

Successfully installed bundler-1.6.2

Successfully installed hike-1.2.3

Successfully installed multi_json-1.10.0

Successfully installed tilt-1.4.1

Successfully installed sprockets-2.12.1

Successfully installed sprockets-rails-2.1.3

Successfully installed rails-4.1.1

28 gems installed

Installing ri documentation for json-1.8.1…

Installing ri documentation for thread_safe-0.3.3…

Installing ri documentation for tzinfo-1.1.0…

Installing ri documentation for minitest-5.3.3…

Installing ri documentation for activesupport-4.1.1…

Installing ri documentation for rack-1.5.2…

Installing ri documentation for rack-test-0.6.2…

Installing ri documentation for builder-3.2.2…

Installing ri documentation for erubis-2.7.0…

Installing ri documentation for actionview-4.1.1…

Installing ri documentation for actionpack-4.1.1…

ERROR: While generating documentation for actionpack-4.1.1

… MESSAGE: Invalid argument - ./ActionDispatch/Routing/Mapper/Scoping/:

… RDOC args: --ri --op C:/Ruby193/lib/ruby/gems/1.9.1/doc/actionpack-4.1.1/ri lib --title actionpack-4.1.1 Documentation --quiet

I have run into the same issue. Different from the OP, I am new to Rails
so probably cannot live so well without documentation.

Has anybody else run into this and found a solution?

You may well find it difficult to get help with problems on Windows as
most developers use Linux (eg Ubuntu) or Mac. I suggest either set
you machine to dual boot with, for example, Ubuntu and start again.
Alternatively you can run linux in a virtual machine inside windows
using vmware or virtualbox.

Then I advise using rvm for installing ruby and rails, others like
rbenv I believe.

If you really must use Windows then I understand railsinstaller is the
preferred route.

Colin

I also ran into this issue but on windows 8. After hours of working on installing and uninstalling and researching how to fix this problem,even coming across this before solving it, at last i did well at least for me. So to hopefully help out those out those that are new to ruby “on rails”, like myself, and prevent them from the hours of headache here it is… first use the command " gem uninstall rails “. If you did like I did over time and installed more then one version it will ask which one to delete. The last option is to delete all versions this is the one you want to pick. So type in the corresponding number and hit enter. Then use the command " gem clean " or some new versions " gem cleanup” that will clear everything left including bundle and anything else you installed using gems. So after installing them back you can proceed to using the command " gem install ruby --pre ". If by some chance you do get the same error, dont worry, type in this final command " gem install ruby -v 4.1.1 " this one will start off fast because it is skipping over the stuff already installed correctly and then it will be on getting the documents for a wail. Just be patient and when you finally see “1 gem installed” lol you are riding ruby on rails! Hope this helps :slight_smile: