Need suggestions: Plugin for ruby 1.9.3

Hello Everyone,

My rails application is executing currently in ruby 1.8.7 + rails 2.3.4 combo and I am panning to migrate this to rails 2.3.4 + ruby 1.9.7 combo. While doing so, in the first step, I have got some syntax errors in the plugins which requires me to manually go and fix that issue occurring in plugin. I just got one question in my mind while fixing around them, “why can’t we upgrade the plugins to support ruby 1.9.7?”

But I have tried to find the plugins / solution for ruby 1.9.7 but no luck and hence finally landed here :). Could any one please let me know the feasibility for upgrading the plugin?

Below are the plugins I want to upgrade:

  • Exceptionlogger

  • Rsa plugins

  • healthcheck

Suggestions are welcome!

Thanks in advance,

Seeni Rafiyullah Khan A,

I presume you mean Ruby 1.9.3? Why bother though, rails 2.3 is fine
with 1.8.7? I would be more concerned about migrating to Rails 3 or
at least the latest version of 2.3

Colin