Mysql and Snow leopard

I can’t get mysql gem installed on snow leopard. On Leopard (10.5) all I did was

sudo gem install – --with-mysql-config=/path/to/mysql_config

But that doesn’t work any more, and i get tons of

No definition for XXX

Ideas ?

Trausti

I think those are just warnings. It's trying to generate docs.

Does the install actually work?

jeremy

Not checked that much.

Trausti

I had a lot of trouble Saturday as well with this..

I found you need to install the 64bit v. and set your paths
accordingly.

plus this was the link that helped get it running finally with my
current applications

http://void-design.net/2009/08/05/ruby-191-mysql-and-a-snow-leopard/

chekc it out. hope it helps

Can you post the entire message?

According to the Rails blog you need to expressly force it to be
compiled in 64-bit (which worked for me):

$ sudo env ARCHFLAGS="-arch x86_64" gem install mysql -- --with-mysql-
config=/usr/local/mysql/bin/mysql_config

(source http://weblog.rubyonrails.org/2009/8/30/upgrading-to-snow-leopard)

Did you upgrade your mysql install to a 64-bit version?

I just got Ruby, MySQL and everything working on Snow Leopard.
The key, in my experience, is installing MySQL from MacPorts and NOT
from the MySQL provided packages.

Rather than repeat myself, I documented it all here:
http://blog.twg.ca/2009/09/livin-on-the-edge-ruby-rails-and-snow-leopard/

Hope this helps...

Alex wrote:

I seem to be working after:

  1) Installing the 64-bit intel os x binary from mysql.com
        I also installed the mysql preference pane from there
  2) sudo env ARCHFLAGS="-arch x86_64" gem install mysql

I do get warnings from the doc generation when I install the gem, not
sure how to fix that, but it seems to work.

Also note that there's a new post-leopard version of passenger pref
pane out there, although I was working with the previous one before as
far a I know.

All I did was sudo port uninstall mysql and then sudo port install
mysql... done. :slight_smile:
then
sudo gem uninstall mysqlplus && sudo gem install mysqlplus

But I guess if you need a specific version of MySQL...

After installing mysql 64 bit, that did the trick.

But passenger gives me this error :

[Thu Sep 03 18:17:57 2009] [notice] child pid 85922 exit signal Bus error (10)

[Thu Sep 03 18:17:57 2009] [notice] child pid 85921 exit signal Bus error (10)

[Thu Sep 03 18:17:57 2009] [notice] child pid 85920 exit signal Bus error (10)

And still does not work.

I am using XAMPP, and it works if I disable passenger.

I have uninstalled passenger and re-installed to no avail.

Trausti

Stupid question, but did you (re)install the appriate apache/nginx
module? You might have a 32/64 bit mismatch.

I did run the passanger-install-apache-modules

Trausti