[Linux] Error installing rails "activemodel requires activesupport"?

Well, I'm trying to install Rails through gems in a Linux box `sudo gem i rails --pre` I'm getting this:

ERROR: Error installing rails:        activemodel requires activesupport (= 3.1.0.rc6, runtime)

Which is funny, because when I check `gem list` I get

activesupport (3.1.0.rc6) bcrypt-ruby (2.1.4) builder (3.0.0) i18n (0.6.0) multi_json (1.0.3)

I don't know what to do :expressionless:

For the record, I just installed Ruby through RVM and it solved it.

Please follow this Github repo for exact steps to prevent errors in future:


"One click" shell script for Git+RVM+Ruby+Rails with all packages required is in progress: https://github.com/davidpgero/rvm_install_script

If you've further question or problems with the steps or with install script please let us know. Good luck, gezope