Issues with Github Codespaces setup to Contribute to Rails

Hello everyone, I forked the rails repo and I opened it in Github Codespaces. After running bundle install, I wanted to run some tests but I kept getting this error:

    Your lockfile doesn't include a valid resolution.
    You can fix this by regenerating your lockfile or trying to manually editing the bad locked gems to a version that satisfies all dependencies.
    The unmet dependencies are:
    * activesupport (>= 3.0, < 6.2), depended upon delayed_job-4.1.9, unsatisfied by activesupport-7.1.0.alpha
    * activerecord (>= 3.0, < 6.2), depended upon delayed_job_active_record-4.1.6, unsatisfied by activerecord-7.1.0.alpha

I tried updating bundler and downgrading the gems in questions to fix the dependency issue. Neither worked. I double checked and according to the Rails contribution guide,

the Codespace is initialized with all required dependencies and allows you to run all tests.

Did I miss something or is this an expected behavior? Thanks!

This “error” is just a warning. It should not impact the setup, and you can just ignore it.

I faced similar kind of issue last time, I am still searching for some proper solution.

I see. Thanks! I will send a patch to the Rails documentation regarding this for future reference.