Issues bundling/running app migrated from Rails 4.1 to 4.2

Have a running Rails 4.1.16 app. Upgraded to 4.2.11.3. I had to add (pin) rb-inotify to (0.9.10). Running the app gives "Function ‘inotify_init’ not found in [libc.dylib] " at ffi-1.9.6/lib/ffi/library.rb:261:in `attach_function’. Tried earlier versions of rb-inotify with same result (until getting to 0.9.5, where I got “could not find compatible versions for gem ‘rb-inotify’” because sass-listen 4.0.0 was requiring rb-inotify 0.9.7).

Pretty much got this resolved by pinning other gems to versions that did not require rb_inotify.