Ruby 1.8.6 + Rails 1.2.3 + ErrorNotification == NameError !?

Hallo Everybody,

I updated recently to the latest versions of Ruby and Rails. Now it seems to me that the plugin ErrorNotification doesn't run anymore. I even tried to create a new project, installed the plugin and added the following line to my development.rb:

[code] ExceptionNotifier.exception_recipients = "" [/code]

When I try to start my server it hangs with an error. I tried it on Mac and Windows, in development- and production-mode, with webrick and mongrel and I'm always getting the following error:

[code] /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/ active_support/dependencies.rb:477:in const_missing': uninitialized constant Rails::Initializer::ExceptionNotifiable (NameError)         from /Users/dm/Documents/rails/pws_de/config/../config/ environments/development.rb:58:in load_environment'         from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:204:in `load_environment'         from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.2/lib/ active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'         from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:201:in `load_environment'         from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:85:in `process'         from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:43:in `send'         from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:43:in `run'         from /Users/dm/Documents/rails/pws_de/config/environment.rb:13          ... 11 levels...         from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/ mongrel/command.rb:211:in `run'         from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/ mongrel_rails:243         from /usr/local/bin/mongrel_rails:16:in `load'         from /usr/local/bin/mongrel_rails:16


Has anybody an idea, what could be the problem?

Thanks in advance

Did anybody encounter a similar problem?

alright, I found the problem. i had rails installed. uninstalled it and everything was working fine again.

ps: didn't work either.