install/enable openssl for rails 2.0.2

I was trying to install Redmine on rails 2.0.2 and I received the
following error message:

no such file to load -- openssl

I went to /ruby-1.8.6/ext/openssl and typed make and received the
following error message:

make: Nothing to be done for `all'.

My question is: How can I install or enable openssl for ruby 1.8.6 in
order to complete my install for rails.

Thank you!

I was trying to install Redmine on rails 2.0.2 and I received the
following error message:

no such file to load -- openssl

I went to /ruby-1.8.6/ext/openssl and typed make and received the
following error message:

make: Nothing to be done for `all'.

Have you run
make install

It might be worth trying it from scratch:

ruby extconf.rb
make clean
make
make install

Fred

Frederick Cheung wrote:

Have you run
make install

It might be worth trying it from scratch:

ruby extconf.rb
make clean
make
make install

Fred

Thank you for your reply.

here is what happened:

Sounds like you either don't have the development stuff for openssl
(may be in a separate package) or it's somewhere that extconf.rb
couldn't find. You might to pass --with-openssl-include and --with-
openssl-lib options to tell it where openssl is.

Fred

Frederick Cheung wrote:

Sounds like you either don't have the development stuff for openssl
(may be in a separate package) or it's somewhere that extconf.rb
couldn't find. You might to pass --with-openssl-include and --with-
openssl-lib options to tell it where openssl is.

Fred

Problem solved! For anyone else with the same issue... here is what i
did:

install openssl:

    ./config --prefix=/usr/local --openssldir=/usr/local/ssl
    make
    make test
    make install (as root)
    ./config shared --prefix=/usr/local --openssldir=/usr/local/ssl
    make clean
    make
    make install (as root)
    cd /usr/local/ssl/lib
    cp * /usr/lib

To avoid getting the following error later when you compile OpenSSH:

    configure: error: Your OpenSSL headers do
    not match your library

copy all the SSL include files everywhere:

    cd /home/tjnelson/openssl/openssl-*
    cd include/openssl
    cp * /usr/include
    cp * /usr/local/ssl/include
    cp * /usr/local/ssl/include/openssl

and then add /usr/local/ssl/lib to /etc/ld.so.conf and type

    ldconfig

Then i returned to ruby-*/ext/openssl and ran:

ruby extconf.rb
make clean
make
make install

worked like a charm!!!

thanks for all of your help