Again .. Proplem while creating new ruby project

hello everyone,
i have a proplem while creating new application .
when i starting the WEBrick Built-in Server by writing the command
ruby script/server in the directory of the project ,it's appear to me
a long Error Message
it's here :
http://pastie.caboo.se/145093.txt
i uses the rubygems version 1.0.1 and the rails 2.0.2 and openssl in
the latest version .
thnx

This error is stating that the openssl extension for your ruby is not
present. More information is needed in order to fix this. Try
remaking the openssl extension:

1. cd to the ruby distro
2. cd ext/openssl
3. ruby extconf.rb
4. make
5. [sudo] make install

thnx Reacher for solution ,but this proplem appear to me while
executing ruby extconf.rb
=== OpenSSL for Ruby configurator ===
=== Checking for system dependent stuff... ===
checking for t_open() in -lnsl... no
checking for socket() in -lsocket... no
checking for assert.h... yes
=== Checking for required stuff... ===
checking for openssl/ssl.h... no
=== Checking for required stuff failed. ===
Makefile wasn't created. Fix the errors above.

so how can i fix this new Proplem ???!!!!

It's failing to find the openssl header file (that is, the openssl
development directories are not in your path). Lets say your openssl
was built into the folder /usr/local/openssl

ls /usr/local/openssl

bin include lib

Then you can pass this parameter to the config script:

ruby extconf.rb --with-openssl-dir=/usr/local/openssl

There are other params too like --with-openssl-include-dir, --with-
openssl-lib-dir, etc

thnx alot aboy help me in this proplem ,i do what u said above but the
problem still alive , i downloaded the last version of openssl in it's
official site in this link:
http://www.openssl.org/source/openssl-0.9.8g.tar.gz ,and install the
source of ruby again from the official site and install both the
openssl and ruby ,
coz i think thats the lack of lib can be found in the source but
after setup the problem still alive !!!!
any other solution ??

It's failing to find the openssl header file (that is, the openssl
development directories are not in your path). Lets say your openssl
was built into the folder /usr/local/openssl

> ls /usr/local/openssl

bin include lib

Then you can pass this parameter to the config script:

> ruby extconf.rb --with-openssl-dir=/usr/local/openssl

There are other params too like --with-openssl-include-dir, --with-
openssl-lib-dir, etc

--with-openssl-include-dir does not work for me.

I think --with* options need to get passed to the toplevel ruby ./
configure script. Then run the make and the openssl extension should
build. Check the notes in this thread

http://www.groupsrv.com/computers/about65075.html