I am getting following error while running the rails s.

[WARNING] Please install gem ‘therubyracer’ to use Less.

C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bundle/ruby/1.9.1

/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `require’:

cannot load such file – v8 (LoadError)

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `block in require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:236:i

n `load_dependency’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less/java_script/v8_context.rb:2:in `<top (req

uired)>’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `block in require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:236:i

n `load_dependency’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less/java_script.rb:9:in `default_context_wrap

per’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less/java_script.rb:17:in `context_wrapper’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less/loader.rb:13:in `initialize’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less.rb:14:in `new’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less.rb:14:in `module:Less

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-2.4.0/lib/less.rb:9:in `<top (required)>’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `block in require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:236:i

n `load_dependency’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-rails-2.4.2/lib/less/rails.rb:6:in `<top (required)>’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `block in require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:236:i

n `load_dependency’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:i

n `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/less-rails-2.4.2/lib/less-rails.rb:1:in `<top (required)>’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runti

me.rb:72:in `require’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runti

me.rb:72:in `block (2 levels) in require’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runti

me.rb:70:in `each’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runti

me.rb:70:in `block in require’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runti

me.rb:59:in `each’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runti

me.rb:59:in `require’

from C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:13

2:in `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/config/appl

ication.rb:7:in `<top (required)>’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/railties-3.2.16/lib/rails/commands.rb:53:in `require’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/railties-3.2.16/lib/rails/commands.rb:53:in `block in <top (r

equired)>’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/railties-3.2.16/lib/rails/commands.rb:50:in `tap’

from C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bund

le/ruby/1.9.1/gems/railties-3.2.16/lib/rails/commands.rb:50:in `<top (required)>

from script/rails:6:in `require’

from script/rails:6:in `’

Anyone face the same problem. I could not able to figure it out.

Thanks,

Senthil

[WARNING] Please install gem 'therubyracer' to use Less.

Is therubyracer in your Gemfile as the above message suggests?

Fred

C:/Users/srinisen/Documents/aptana_studio_workspace/HEI/vendor/bundle/ruby/1.9.1
/gems/activesupport-3.2.16/lib/active_support/dependencies.rb:251:in `require':
cannot load such file -- v8 (LoadError)

e'