Error installing therubyracer

I'm struggling to install therubyracer gem. Using CentOS 6.2 x86_64,
ruby 1.9.3p194, gem 1.8.24, libv8 (3.10.8.0, 3.3.10.4 x86_64-linux)

Trying to install therubyracer gives me:

Building native extensions. This could take a while...
ERROR: Error installing therubyracer:
        ERROR: Failed to build gem native extension.

        /usr/local/bin/ruby extconf.rb
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/local/bin/ruby
extconf.rb:15:in `<main>': undefined method `include_path' for
Libv8:Module (NoMethodError)

Gem files will remain installed in /usr/local/lib/ruby/gems/1.9.1/gems/
therubyracer-0.10.1 for inspection.
Results logged to /usr/local/lib/ruby/gems/1.9.1/gems/
therubyracer-0.10.1/ext/v8/gem_make.out

Any ideas?

Don't suppose anyone else has had any problems installing
therubyracer? Is there anything particular to look out for installing
on 64-bit linux?

Try this:

$ gem uninstall libv8
$ gem install therubyracer

It works for me.

Rails hosts, for instance Heroku, are strongly advising against therubyracer because of memory usage.

I removed therubyracer from my gems and just did $sudo apt-get install nodejs.

Not sure if that is the preferred method, but it works for me.

Just wanted to mention that I performed the steps mentioned by Meck Z.
on osx lion to deal with the same issue. (was playing with fatfreecrm
which now apparently uses therubyracer). Thanks!

I found a similar problem, but got a little nugget of info in the error
on OS X 10.8 Mountain Lion:

make
compiling rr.cpp
make: g++-4.2: No such file or directory
make: *** [rr.o] Error 1

I found that all you need to do on Mountain Lion is:

1: Make sure you've installed Xcode command line tools so that the g++
directory is in /usr/bin
2: Type "sudo ln -s g++ g++-4.2"

Enjoy :slight_smile:

Thanks zorz that worked for me. However anytime I type anything in
terminal I get this line after:

"-bash: __git_ps1: command not found"

is there a way to get rid of this?

@johnrlive install git with homebrew rather than relying on the os x
version.

Meck Z. wrote in post #1061376:

Try this:

$ gem uninstall libv8
$ gem install therubyracer

It works for me.

Worked for me too.

There's an official Omnibus package for the RPi2, see 'Omnibus package
for Raspberry Pi 2' on https://about.gitlab.com/installation/