having terrible issue with resque ( & redis? ) spend 3 full days debugging. Can't assign requested address - connect(2). Anyone knows a solution?

Anyone knows a solution to below trace, resque no longer startsup and I seriously need it for my app. ( development environment )
I hope somone knows an answer Im even willing to pay for a solution since im totally halted in developments since I need resque as an integral part of my app.

dev2:books jordan$ bundle exec rake resque:start

:public is no longer used to avoid overloading Module#public, use :public_folder instead

from /Users/jordan/.rvm/gems/ruby-1.9.3-p194/gems/resque-1.8.2/lib/resque/server.rb:11:in `<class:Server>'

:public is no longer used to avoid overloading Module#public, use :public_folder instead

from /Users/jordan/.rvm/gems/ruby-1.9.3-p194/gems/resque-1.8.2/lib/resque/server.rb:11:in `<class:Server>'

rake aborted!

Can't assign requested address - connect(2)

Tasks: TOP => resque:work

(See full trace by running task with --trace)

*** Starting worker dev2.local:5191:critical,high,low, books

** [04:56:44 2012-06-08] 5191: Registered signals

:public is no longer used to avoid overloading Module#public, use :public_folder instead

from /Users/jordan/.rvm/gems/ruby-1.9.3-p194/gems/resque-1.8.2/lib/resque/server.rb:11:in `<class:Server>'

rake aborted!

Can't assign requested address - connect(2)

Tasks: TOP => resque:scheduler

(See full trace by running task with --trace)

2012-06-08 16:56:51 Schedule empty! Set Resque.schedule

:public is no longer used to avoid overloading Module#public, use :public_folder instead

from /Users/jordan/.rvm/gems/ruby-1.9.3-p194/gems/resque-1.8.2/lib/resque/server.rb:11:in `<class:Server>'

[2012-06-08 16:56:53 +0200] Starting 'resque-web'...

[2012-06-08 16:56:53 +0200] trying port 5678...

Tried the following:
- Upgrade to latest redis
- Downgrade to 1 version down for resque
- Reset all configurations to default
- Looking true the resque gem code
- Check if the port it wants to connect to is open ( all default ports )
- Upgraded to the latest resque gem

Only the resque-web deamon loads up but will display same error if you go localhost:3000/resque ( the mounting point )

When starting resque normally:

bundle exec rake resque:start --trace

** Invoke resque:start (first_time)

** Invoke resque:workers:start (first_time)

** Execute resque:workers:start

rake aborted!

Can't assign requested address - connect(2)

Tasks: TOP => resque:work

(See full trace by running task with --trace)

*** Starting worker dev2.local:4323:critical,high,low

** [09:01:12 2012-06-15] 4323: Registered signals

** Invoke resque:scheduler:start (first_time)

** Execute resque:scheduler:start

rake aborted!

Can't assign requested address - connect(2)

Tasks: TOP => resque:scheduler

(See full trace by running task with --trace)

2012-06-15 21:01:20 Schedule empty! Set Resque.schedule

** Invoke resque:web:start (first_time)

** Execute resque:web:start

/Users/jordan/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/open-uri.rb:346:in `open_http': 500 Internal Server Error (OpenURI::HTTPError)

This is telling you there’s already something on a port that something is trying to use. As the error message suggests, try running the task with --trace to get a full trace - it will be much easier for people to troubleshoot over the list with a backtrace.

–Matt Jones

Dear Matt,

The first error output is with trace, the problem is no real exact location
and the port is really not in use although the message tells so, ive checked the ports before running the rake task and there is nothing open.
From the trace there is also no real exact line number from the gem code where things go wrong. So this makes it very hard to debug. I try to install resque on my production server and see if it has the same issue there really out of options on this one. Thats why I posted it here and on stack.