gem 'rack', '2.0.1' error from bundler

What’s wrong with " gem ‘rack’, ‘2.0.1’ " in my Gemfile ?

Here’s the error I get when I run bundle install:

Bundler could not find compatible versions for gem “rack”:
In Gemfile:
rack (= 2.0.1)

rails (= 5.0.0.1) was resolved to 5.0.0.1, which depends on
  actionpack (= 5.0.0.1) was resolved to 5.0.0.1, which depends on
    rack (~> 2.0)

mailcatcher (= 0.6.5) was resolved to 0.6.5, which depends on
  rack (~> 1.5)

sass-rails (~> 5.0.6) was resolved to 5.0.6, which depends on
  sprockets (< 4.0, >= 2.8) was resolved to 3.7.0, which depends on
    rack (< 3, > 1)

thin (= 1.5) was resolved to 1.5.0, which depends on
  rack (>= 1.0.0)

Here’s my Gemfile, I removed the Gemfile.lock file so it wouldn’t be relevant So what’s wrong with " gem ‘rack’, ‘2.0.1’ " in my Gemfile ?

source ‘https://rubygems.org

gem ‘railties’, ‘5.0.0.1’
gem ‘rack’, ‘2.0.1’
gem ‘rails’, ‘5.0.0.1’
gem ‘rake’, ‘11.2.2’
gem ‘mysql2’
gem ‘sass-rails’, ‘~> 5.0.6’
gem ‘uglifier’, ‘>= 1.3.0’
gem ‘jquery-rails’
gem ‘jbuilder’, ‘~> 2.0’
gem ‘sdoc’, ‘~> 0.4.0’, group: :doc
gem ‘spring’, group: :development
gem ‘thin’, ‘1.5’
gem ‘devise’
gem ‘will_paginate’, ‘~> 3.0’
gem ‘carrierwave’
gem ‘mini_magick’
gem ‘mailcatcher’, ‘0.6.5’

group :development, :test do
gem ‘simplecov’, ‘~> 0.7.1’, :require => false
gem ‘rspec-rails’, ‘~> 2’
gem ‘shoulda-matchers’
gem ‘faker’
gem ‘pry-byebug’
gem ‘mocha’
gem ‘cucumber-rails’, :require => false
gem ‘database_cleaner’
gem ‘launchy’
end

Hi,

What's wrong with " gem 'rack', '2.0.1' " in my Gemfile ?

Here's the error I get when I run bundle install:

Bundler could not find compatible versions for gem "rack":
  In Gemfile:
    rack (= 2.0.1)

    rails (= 5.0.0.1) was resolved to 5.0.0.1, which depends on
      actionpack (= 5.0.0.1) was resolved to 5.0.0.1, which depends on
        rack (~> 2.0)

    mailcatcher (= 0.6.5) was resolved to 0.6.5, which depends on
      rack (~> 1.5)

The problem is with mailcatcher which isn't designed to be put in
Gemfile (version conflicts).

Quoting from the README: