Bundler could not find compatible versions for gem "bundler":

Hey everyone,

I just ran into the following errors while running bundle install. Please advise.

Bundler could not find compatible versions for gem “bundler”:
In Gemfile:
rails (= 4.2.4) was resolved to 4.2.4, which depends on
bundler (>= 1.3.0, < 2.0)

Current Bundler version:
bundler (2.0.1)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running gem install bundler?

Could not find gem ‘bundler (>= 1.3.0, < 2.0)’, which is required by gem ‘rails
(= 4.2.4)’, in any of the sources.

Bundler could not find compatible versions for gem “coffee-rails”:
In Gemfile:
coffee-rails (~> 4.1.0)

This might shed some light on specifically dealing with it but basically you need to use a version of Bundler that the Gemfile will accept, because yours is too new for that particular Rails:

https://stackoverflow.com/questions/12092928/how-to-bundle-install-when-your-gemfile-requires-an-older-version-of-bundler