Face Problem to create a new app

I create a new app => rails new demo



create vendor/assets/stylesheets
create vendor/assets/stylesheets/.keep
run bundle install
/var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/ui.rb:36:in initialize': undefined method []’ for #Thor::Shell::Color:0xa3b635c (NoMethodError)
from /usr/lib/ruby/vendor_ruby/bundler/cli.rb:12:in new' from /usr/lib/ruby/vendor_ruby/bundler/cli.rb:12:in initialize’
from /usr/lib/ruby/vendor_ruby/bundler/vendor/thor.rb:263:in new' from /usr/lib/ruby/vendor_ruby/bundler/vendor/thor.rb:263:in dispatch’
from /usr/lib/ruby/vendor_ruby/bundler/vendor/thor/base.rb:386:in start' from /var/lib/gems/1.9.1/gems/bundler-1.3.5/bin/bundle:20:in block in ’
from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/friendly_errors.rb:3:in with_friendly_errors' from /var/lib/gems/1.9.1/gems/bundler-1.3.5/bin/bundle:20:in

I have a rails3 & ruby 1.9.1
After that i try to install bundle, but it will give a error

Bundler could not find compatible versions for gem “bundler”:
In Gemfile:
rails (= 4.0.0) ruby depends on
bundler (< 2.0, >= 1.3.0) ruby

Current Bundler version:
bundler (1.1.4)

This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running gem install bundler?

Please let me know where i am wrong,

Thanks…
Tushar Patil.

Tushar Patil wrote in post #1115001:

I create a new app => rails new demo

I have a rails3 & ruby 1.9.1
After that i try to install bundle, but it will give a error

I thought Ruby 1.9.1 was completely broken when trying to run Rails. Try
Ruby 1.9.3.

Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (= 4.0.0) ruby depends on
      bundler (< 2.0, >= 1.3.0) ruby

This is indicating Rails 4.0.0. I'm quite sure that won't work properly
with Ruby 1.9.1. Compatible versions for Rails 4 are Ruby 1.9.3 and
2.0.0.

  Current Bundler version:
    bundler (1.1.4)

The current version of Bundler is 1.3.5 and it compatible with the
current release of Rails 4.0.0.

This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Please let me know where i am wrong,

Did you do as suggested and run "gem install bundler"?