gem install error for activesupport - wrong version

I installed rails 2.1.0
I updated my gems with the following commands

gem update --system
gem update --source http://gems.rubyonrails.org

But when I run ruby script/server, I get the following error:

C:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:578:in
`report_activate_
error': RubyGem version error: activesupport(2.1.0 not = 1.4.2)
(Gem::LoadError)

Yes, my active support is not 1.4.2 as I updated it to 2.1.0. What can
I do here.

Thanks

Changed environment.rb to

RAILS_GEM_VERSION = '2.1.0' unless defined? RAILS_GEM_VERSION

and it worked.