Gem install bundler works, gem bundle doesn't?

Hi, I'm having some trouble with bundler:

-bash-4.1$ gem install bundler
Successfully installed bundler-1.0.21
1 gem installed
Installing ri documentation for bundler-1.0.21...
Installing RDoc documentation for bundler-1.0.21...

-bash-4.1$ bundle install
ERRRO: Gem bundler is not installed, run `gem install bundler` first.

Could you share a bit more info with us?

Share your gem environment ("gem environment")

and gem list.

I've had experiences here at work where people were installing gems to
the wrong directory, one not in their gem path.

Have you tried it with sudo?

Hello. I'm having the exact same problem. I'm on a hosted plan where I
don't have root access. I am using RVM.

gem environment output:
http://fpaste.org/9Ek4/

I can also type which bundle:
/home/giglinke/.rvm/bin/bundle

But anything else (bundle -v, bundle install, etc.) gives me the error
reported above.

gem install bundle works exactly as original poster listed.

...is this an rvm thing?

Any ideas?

Francesca Krihely wrote in post #1042676:

I also have this problem but I have root access.
Are there any options?

Hello all!

I had this same problem, and the solution was:

- rename the Gemfile.lock (ex: Gemfile.lock.old )
- delete Gemfile.lock
- run bundle

With this it worked for me.

See you!

I have all files (Gemfile.lock) moved to Gemfile.lock.old

After that I installed "bundler" again but i got the same error... :frowning:

I had Installed Bundler and when I executed it tells me this:

ERRRO: Gem bundler is not installed, run `gem install bundler` first.

After that I renamed just Gemfile.lock and next I removed it.
I didn't install again bundler because I had it, then just execute
bundle or bundle install, as you like, and it worked well for me.

I can't tell you more if I have no logs.

By the way I had this problem after clone a project from github, because
the Gemfile.lock was uploaded to the project repository.

¡Saludos!