Forcing FCGI at dreamhost

Jason Pfeifer wrote:

Greetings all,

I've got an app in production at dreamhost, but I can't seem to force
FCGI on it. I have it enabled for the domain in the admin panel, have
checked the file permissions in my public folder, and tried firing the
scripts from the command line.

When firing either dispatch.cgi, or dispatch.fcgi from the command line,
I get a 500 internal server error on BOTH.

But, if I look at my app in a browser it runs fine but really slow. If
I go and rename dispatch.cgi the app doesn't work, so I think it's
running under dispatch.cgi

I've used pico to resave the files and make sure the line-endings are
correct too. Is there anything I'm missing to put it into FastCGI, or
reccomendations for checking or debugging the issue?

Have you look at the .htaccess file? I think by default it has CGI enabled.
You may have to edit the file and enable the FCGI dispatcher instead.

Hopefully it will work.

Long
www.edgesoft.ca/blog/read/2