Dreamhost problem

This is my first post here and I am somewhat of a rookie but I have
been practcing...

I recently started having problems with a Dreamhost rails site that
was working fine up until a weeks ago. I created a test site and am
having the same problem.

The browser is either pulls the 500 error from public/.htaccess or
from public/500.html. Mostly from .htaccess.

The test site is below. There is only one model.
http://www.test.sunnybeachdesign.com/

The error log file reads:
[Wed Jul 25 10:48:38 2007] [error] [client 207.75.xxx.XXX] FastCGI:
comm with (dynamic) server
"/home/sbeach/test.sunnybeachdesign.com/public/dispatch.fcgi" aborted:
(first read) idle timeout (60 sec)
[Wed Jul 25 10:48:38 2007] [error] [client 207.75.xxx.XXX] FastCGI:
incomplete headers (0 bytes) received from server
"/home/sbeach/test.sunnybeachdesign.com/public/dispatch.fcgi"

I have been looking though list archives, wikis, etc but have not
found anything that brings the original one back to life or makes the
new one work.

An initial email to their support was not helpful... (fix your own
app) but as my attempts continue to fail I tend to think it is on
their end.

Does anyone have any advice or recommendations?

I had that problem. I had to contact Dreamhost a few times to get it resolved. They never explained what it was.

One thing that you could try is disabling fastcgi for that domain, and then re-enable it about 5 hours later. That sometimes fixes that error.

Dreamhost is great and cheap, and works nice when it works, but when you have problems, it’s terrible.

+1 on RailsPlayground.com.

Check the first line in the dispatch.fcgi file. It should read #!/usr/bin/env ruby and not #!/usr/bin/ruby1.8 . Dreamhost is not that bad, but most of the solutions to the problems can solved by looking through the wiki.

That kind of logic applies to everything. Even the blessed Rails! :wink:

RSL

Just wanted to say thanks for the replies. I got the app working again
with Dreamhost. They promised that they did not touch the server...
but a couple emails to them seemed to help. Maybe it was just the
passage of time.

The only substantial change was to config/environment.rb. I added
"unless defined? RAILS_GEM_VERSION" to line 8 so it now reads
"RAILS_GEM_VERSION = '1.2.3' unless defined? RAILS_GEM_VERSION"

For Richard, dispatch.fcgi is currently cooperating with
#!/usr/bin/ruby1.8 as the first line. I did try your solution along
with a few others I found online.

Overall I like Dreamnost and would recommend them. If I ever get to
the point where my apps are critical, it will be time to upgrade.

Sunny

PS. Apologies for the poor English in the first post... I was a little
frustrated at that point.

Also keep in mind that the servers take about 5-10 mins to restart after a change has been made.