Errors on installing Rails on windows 7 (32 bit)

Hi, I'm trying to install Rails, but when installing the Rails package
using Gem, I get some errors. See error log in bottom of this post.

I'm new to Rails as well as Ruby, and was trying to do the steps
described in the official Rails web page at http://rubyonrails.org/community

I'm using Windows 7 (32 bit), and have just installed Ruby 1.8.7 (as
there is curently a bug that prevents me from installing the Gem
package manager on 1.9.2, as described here:
http://rubyforge.org/tracker/index.php?func=detail&aid=28744&group_id=126&atid=575)
and the Gem package manager.

I just want to get Rails running, can anyone help?

Did you ever get this working? I have the same issue but on Ubuntu 10.10