error upgrading InstantRails on WinXP, 'could not find rails gem locally or in a repository'

I'm trying to upgrade to the latest version of rails. I've been
happily using InstantRails2-0 for awhile and it's been great.
However, I've hit problems trying to upgrade. I get the error in the
subject when I do 'gem install rails'.

I've read the Rails Wiki about upgrading rails and it doesn't have any
info on this error. The Rails Wiki said I needed to first do
update_rubygems, and it appears I was able to do that successfully. My
ruby version is 1.8.6. I googled this particular error and got a few
hits about making sure the gem sources included gems.rubyonrails.org,
which mine does.

I also found an article that suggested I download the latest rails
from github, which I also tried.

Turns out the gem update didn't work, after I checked my gem version
and found it was 1.2. When I do 'gem install rubygems-update', I get
the same error:

'could not find gem rubygems-update locally or in a repository'

What am I doing wrong?

May be: gem update system?