Devise routing to views inside of gem for one of my models

I can't seem to figure out why Devise is falling back to the gem views
for one* of the user models.

Here are my routes and the link that I'm using to connect to the new
action for the registration form.

Available Devise Routes
           POST /registration.biz_user(.:format)
devise/registrations#create
           biz_users_sign_out GET /biz_users/sign_out(.:format)
devise/sessions#destroy
         new_biz_user_session GET /biz_users/login(.:format)
devise/sessions#new
             biz_user_session POST /biz_users/login(.:format)
devise/sessions#create
     destroy_biz_user_session DELETE /biz_users/logout(.:format)
devise/sessions#destroy
            biz_user_password POST /biz_users/password(.:format)
devise/passwords#create
        new_biz_user_password GET /biz_users/password/new(.:format)
devise/passwords#new
       edit_biz_user_password GET /biz_users/password/edit(.:format)
devise/passwords#edit
                              PATCH /biz_users/password(.:format)
devise/passwords#update
                              PUT /biz_users/password(.:format)
devise/passwords#update
cancel_biz_user_registration GET /biz_users/cancel(.:format)
devise/registrations#cancel
        biz_user_registration POST /biz_users(.:format)
devise/registrations#create
    new_biz_user_registration GET /biz_users/register(.:format)
devise/registrations#new
   edit_biz_user_registration GET /biz_users/edit(.:format)
devise/registrations#edit
                              PATCH /biz_users(.:format)
devise/registrations#update
                              PUT /biz_users(.:format)
devise/registrations#update
                              DELETE /biz_users(.:format)
devise/registrations#destroy

  devise_for :biz_users, path_names: { sign_in: 'login', sign_out:
'logout', sign_up: 'register', registrations: 'registrations' }
  devise_for :users, path_names: { sign_in: 'login', sign_out: 'logout',
sign_up: 'register', registrations: 'registrations' }
  devise_for :admins, path_names: { sign_in: 'login', sign_out:
'logout', sign_up: 'register', registrations: 'registrations' }

Link to registration Route/URL
<%= link_to 'Sign Up', new_biz_user_registration_path, class: 'button
success large expand' %>

The views for the biz_users model is inside views/bizusers/sub
directories.

Can you help me wire these views up to their appropriate models?

is that all your routes? There’s not a “get /biz_users/(:something)” or a “get /(:something)” before?