date_select Doesn't Support Multiple Records? No []?

I am submitting multiple records in a single POST.

I am trying to use date_select as follows:

<%= date_select('event_date[]', :occurs_at) %>

Usually, the [] in the object name instructs the tag to put the object ID in
the generated HTML. Works fine for all the other tags but date_select seems
to ignore it.

I'm hoping that I am doing something wrong and date_select doesn't have a
bug...

Anyone know?

Thanks,
HH

I'll respond to my own post.

This is indeed a bug (or whatever).

Anyway, it's fixed:

http://dev.rubyonrails.org/ticket/2655

HH,

I wasn’t able to find it from the ticket you pasted, nor the ticket referred to
by that ticket, but did you see what version of rails this was fixed in? From what
I can clean from the comment stream interspersed with spam comments this

has yet to be merged into trunk.

I ran into this problem back in January, fixed it, and posted this easy fix:

http://javathehutt.blogspot.com/2006/01/rails-realities-part-3-first-rails.html

-Michael

Re: [Rails] Re: date_select Doesn’t Support Multiple Records? No []?
You’re right, it hasn’t been applied yet. I was incorrect – jumped the gun a bit.