[CVE-2022-22577] Possible XSS Vulnerability in Action Pack

There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577.

  • Versions Affected: >= 5.2.0
  • Not affected: < 5.2.0
  • Fixed Versions:,,,


CSP headers were only sent along with responses that Rails considered as “HTML” responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks.


The FIXED releases are available at the normal locations.


Set a CSP for your API responses manually.


To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset.

  • 5-2-csp-xss.patch - Patch for 5.2 series
  • 6-0-csp-xss.patch - Patch for 6.0 series
  • 6-1-csp-xss.patch - Patch for 6.1 series
  • 7-0-csp-xss.patch - Patch for 7.0 series


Thank you Tim Wade for making the patch, and thank you thorsteneckel for reporting this issue.

5-2-csp-xss.patch (3.2 KB) 6-0-csp-xss.patch (3.1 KB) 6-1-csp-xss.patch (3.2 KB) 7-0-csp-xss.patch (3.1 KB)