CRITICAL: Rails 3 error : parser.bundle unhandled exception!!!

kristian-mandrups-macbook-pro:rails3_apps kristianconsult$ rails my_r3
      create
      create README
      create .gitignore
      create Rakefile
      create config.ru
      create Gemfile
      create app
      ...

kristian-mandrups-macbook-pro:my_r3 kristianconsult$ script/console
/Users/kristianconsult/.gem/ruby/1.8/gems/json-1.1.9/ext/json/ext/
parser.bundle: unhandled exception
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:537:in `new_constants_in'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /Users/kristianconsult/.gem/ruby/1.8/gems/json-1.1.9/lib/json/
ext.rb:7
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:537:in `new_constants_in'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /Users/kristianconsult/.gem/ruby/1.8/gems/json-1.1.9/lib/json.rb:
6
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
36:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
36:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:537:in `new_constants_in'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/json/encoding.rb:13
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:537:in `new_constants_in'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/json.rb:2
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:537:in `new_constants_in'
  from /opt/local/lib/ruby/gems/1.8/gems/activesupport-3.0.pre/lib/
active_support/dependencies.rb:167:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activemodel-3.0.pre/lib/
active_model/serializers/json.rb:1
  from /opt/local/lib/ruby/gems/1.8/gems/activerecord-3.0.pre/lib/
active_record/serialization.rb:4
  from /opt/local/lib/ruby/gems/1.8/gems/activerecord-3.0.pre/lib/
active_record/base.rb:2745
  from /opt/local/lib/ruby/gems/1.8/gems/activerecord-3.0.pre/lib/
active_record/base.rb:2724:in `class_eval'
  from /opt/local/lib/ruby/gems/1.8/gems/activerecord-3.0.pre/lib/
active_record/base.rb:2724
  from /opt/local/lib/ruby/gems/1.8/gems/activerecord-3.0.pre/lib/
active_record.rb:142
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/activerecord-3.0.pre/lib/
active_record/railtie.rb:5
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
36:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
36:in `require'
  from /opt/local/lib/ruby/gems/1.8/gems/railties-3.0.pre/lib/rails/
all.rb:12
  from /opt/local/lib/ruby/gems/1.8/gems/railties-3.0.pre/lib/rails/
all.rb:5:in `each'
  from /opt/local/lib/ruby/gems/1.8/gems/railties-3.0.pre/lib/rails/
all.rb:5
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
36:in `gem_original_require'
  from /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
36:in `require'
  from /Users/kristianconsult/my_rails/rails3_apps/my_r3/config/boot.rb:
16
  from script/console:2:in `require'
  from script/console:2

kristian-mandrups-macbook-pro:my_r3 kristianconsult$ gem list bundler

*** LOCAL GEMS ***

bundler (0.8.1, 0.7.1)

kristian-mandrups-macbook-pro:my_r3 kristianconsult$ ruby -v
ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-darwin10]

Any ideas?

Turns out the problem was with the old version of the json gem! Just
needed to upgrade it :slight_smile:

kristian-mandrups-macbook-pro:my_r3 kristianconsult$ sudo gem install
json
Password:
Building native extensions. This could take a while...
Successfully installed json-1.2.0
1 gem installed
Installing ri documentation for json-1.2.0...
Installing RDoc documentation for json-1.2.0...
kristian-mandrups-macbook-pro:my_r3 kristianconsult$ script/console
Loading development environment (Rails 3.0.pre)
irb(main):001:0>