could not find rmagick locally or in a repository

I unzipped simple captcha in vendor/plugins
Then I did

rake simple_captcha:setup

Gave error:
rake aborted!
no such file to load -- RMagick2.so

SO I thought Rmagick has to be installed.

So downloaded
2.12.0 binary gem for Ruby 1.8.6 DT 2009-10-04 16:05
RMagick-2.12.0-ImageMagick-6.5.6-8-Q8.zip

Unzipped the file

Ran ImageMagick-6.5.6-8-Q8-windows-dll.exe
It installed the program in windows/program files directory. I thought
it was supposed to install in Ruby Dr.

Then I did

gem install rmagick --local

gives error: ERROR: could not find gem rmagick locally or in a
repository

I am lost completely with this. Can someopne please help?
I have been struggling with install for 2 days - which should take
couple of minutes.

I thought it was supposed to install in Ruby Dr.

No, ImageMagick is not a ruby library, its a standalone application.

RMagick-2.12.0-ImageMagick-6.5.6-8-Q8.zip contains a file called
"rmagick-2.12.0-x86-mswin32.gem". Extract this file somewhere, for
instance c:\rmagick

On the command prompt run:
cd /rmagick
gem install rmagick --local

Sharagoz -- wrote:

RMagick-2.12.0-ImageMagick-6.5.6-8-Q8.zip contains a file called
"rmagick-2.12.0-x86-mswin32.gem". Extract this file somewhere, for
instance c:\rmagick

On the command prompt run:
cd /rmagick
gem install rmagick --local

Thank you. I got the Rmagick installed as below.

C:\VR\downloads\RMagick-2.12.0-ImageMagick-6.5.6-8-Q8>gem install
RMagick
Successfully installed rmagick-2.12.0-x86-mswin32
1 gem installed
Installing ri documentation for rmagick-2.12.0-x86-mswin32...
Installing RDoc documentation for rmagick-2.12.0-x86-mswin32...

Then I install simple_captcha, I get following error:
C:\VR\RailsPrograms\health\vendor\plugins>rake simple_captcha:setup
(in C:/VR/RailsPrograms/health)
rake aborted!
126: The specified module could not be found. -
C:/Ruby19/lib/ruby/gems/1.9.1/
gems/rmagick-2.12.0-x86-mswin32/ext/RMagick2.so
(See full trace by running task with --trace)

Can you please tell me what else needs to be done.

Its been a while since I worked with imagemagick/rmagick, so I am not
sure.

Is imagemagick added to your windows PATH environment variable?
If not, add it.
(The path is something like "C:\Program Files\ImageMagick-6.5.6-Q16")
And you need to reboot after that is done.

Sharagoz -- wrote:

Its been a while since I worked with imagemagick/rmagick, so I am not
sure.

Is imagemagick added to your windows PATH environment variable?
If not, add it.
(The path is something like "C:\Program Files\ImageMagick-6.5.6-Q16")
And you need to reboot after that is done.

The path is there. I rebooted and ran the command:
rake simple_captcha:setup
Gives error:
The application has failed to start becausee msvcrt-ruby18.dll was not
found. reinstalling the applicaiton may fix the problem.
Which application should I reinstall - ruby, rmagica, simple_captcha

You really should try to do some research on your own before asking
questions in forums. Most questions have already been asked and
answered. Simply googling for "msvcrt-ruby18.dll" results in the answer
at the 2nd hit.

Quote, Tim Hunter, creator of Rmagick:
"RMagick 2 can be built to run with Ruby 1.9.0 when you build RMagick
from source. However, I built the Win32 gem with Ruby 1.8.6. There is no
pre-built version of RMagick that works with Ruby 1.9.0."

What's he's saying is that you'll need ruby 1.8.6 to run Rmagick on
windows, unless you want to try and compile Rmagick from source yourself
with ruby 1.9

Sharagoz -- wrote:

You really should try to do some research on your own before asking
questions in forums. Most questions have already been asked and
answered. Simply googling for "msvcrt-ruby18.dll" results in the answer
at the 2nd hit.

Quote, Tim Hunter, creator of Rmagick:
"RMagick 2 can be built to run with Ruby 1.9.0 when you build RMagick
from source. However, I built the Win32 gem with Ruby 1.8.6. There is no
pre-built version of RMagick that works with Ruby 1.9.0."

What's he's saying is that you'll need ruby 1.8.6 to run Rmagick on
windows, unless you want to try and compile Rmagick from source yourself
with ruby 1.9

Thank you. I know I have to do some searching around before posting.

Vishwa Rao wrote:

Sharagoz -- wrote:

You really should try to do some research on your own before asking
questions in forums. Most questions have already been asked and
answered. Simply googling for "msvcrt-ruby18.dll" results in the answer
at the 2nd hit.

Quote, Tim Hunter, creator of Rmagick:
"RMagick 2 can be built to run with Ruby 1.9.0 when you build RMagick
from source. However, I built the Win32 gem with Ruby 1.8.6. There is no
pre-built version of RMagick that works with Ruby 1.9.0."

What's he's saying is that you'll need ruby 1.8.6 to run Rmagick on
windows, unless you want to try and compile Rmagick from source yourself
with ruby 1.9

Thank you. I know I have to do some searching around before posting.

or use this tips :smiley:

http://www.waydotnet.com/blog/2010/02/rmagick-on-ruby-1-9-1-i386-mingw32-work-d/

WaYdotNET
Carlo Bertini
www.waydotnet.com