Could not find a valid gem 'activerecord-mysql-adapter' (>= 0) in any repository

Hi,

since upgrading my gems from activerecord-3.0.10 to activerecord-3.1.0
my scripts using activerecord don't work anymore. I get an error
message

Error Please install the mysql adapter: `gem install activerecord-
mysql-adapter` (Could not find RubyGem mysql (~> 2.8.1)
)

but gem does not find such a package:

ERROR: Could not find a valid gem 'activerecord-mysql-adapter' (>= 0)
in any repository

it's not even listed on rubygems.org.

How would I get this running?

(And why is rails distributed over such an unreliable distribution way
like gems? Why can't it come as a regular bundle just like any other
software?)

regards
Hadmut

hi were u able to figure the error out?
I'm getting the same error...
except mine gets weirder...
i get:
Please install the adapter: `gem install activerecord--adapter`
if u make any progress on this then please let me know

I have the same issue. Also, I searched on rubygems.org and didn't see
it either. Very strange...

Hope your adapter is not updated on database.yml file, update the adapter as ‘mysql’, then execute ‘bundle install’.

regards,
Loganathan

Loganathan S. wrote in post #1027423:

Hope your adapter is not updated on database.yml file, update the
adapter as
'mysql', then execute 'bundle install'.

regards,
Loganathan

Thanks for that. What I found is on Windows I needed to install a
version not requiring recompiling.

gem install mysql2 -v 0.2.6

-Owen