Found some errors in documentation

Hello,

First: I love the guides! Number one reason I started learning Ruby on
Rails instead of sticking with PHP was because of the excellent
guides.

Now that I am a little more advanced (and I mean little) I still use
it as a reference when setting up a new rails app or writing
migrations. However, today I found an error on the Getting Started
page. I decided to set up my database.yml file with MySQL settings
instead of my normal SQLite setup. In the guide it says:

development:
  adapter: mysql2

but I think it should be simply:

development:
  adapter: mysql

I tried the first one and got an error when generating scaffolding
saying I needed to 'gem install activerecord-mysql2-adapter'. I tried
that and it failed because it couldn't find a gem by that name. So I
tried 'gem install mysql' and it worked fine. Then I tried generating
my scaffolding again but it still had an error, so I changed mysql2 to
mysql and it worked.

Then I tried to figure out how to let someone know that I found this
error and noticed that the link to the github issue tracker was a bad
link. Looks like issues are no longer hosted there. Probably be good
to update that link too.

That's all. Thanks again for the great guides.

--Andrew

Hi Andrew,

mysql2 is a better version of the mysql gem. I used mysql for a while, but it would choke on certain characters like fancier quotation marks and the like. mysql2 is the way to go. If you change the name of a database adapter/gem in your config, you have to add it to your gemfile and install the gem (gem install mysql2, OR, bundle install (if you’re using bundler). In summary, mysql2 and mysql are two different gems, and mysql2 is the better one.

Best,

Gabe