Complex Forms Misbehavior (possibly a Rails bug)

Rails isn't yet comptatible with Ruby 1.9, in my understanding.

///ark

It was released today (Christmas Day).

    http://www.ruby-lang.org/en/news/

However, it is a development release only, so it may not be completely
stable. The know stable version is on the download page and is 1.8.6-
p111.

Ruby 1.9 on Rails 2.0 tests correctly for me. However, Ruby 1.9 on
Rails 1.2 may not.

Also, remember that the Ruby 1.9, released today, is still a
development release, so not everything may be working properly with
the Ruby interpreter.

I got my information from http://blog.codefront.net/2007/12/26/ruby-190-has-been-released/

///ark

Rails isn't yet comptatible with Ruby 1.9, in my understanding.

Ruby 1.9 on Rails 2.0 tests correctly for me. However, Ruby 1.9 on
Rails 1.2 may not.

Have you actually run the rails unit tests? There are still many
failing tests on 1.9

Fred