changing routes.rb

Hi,

I'm a complete beginner and I just have a simple question:
How do I change lines in a file like routes.rb? I know the command type
(i.e type config\routes.rb) but that just shows it and doesn't allow me
to change anything.

Thanks in advance

Hi,

I'm a complete beginner and I just have a simple question:
How do I change lines in a file like routes.rb? I know the command type
(i.e type config\routes.rb) but that just shows it and doesn't allow me
to change anything.

Use your favourite text editor

Fred

Thankyou.

Hey, I'm trying to sort out the routing still, I've generated a home
controller, deleted the public/index.html and changed the routes.rb to
have :root to=> "home#index" and I have changed the html code in
app\view\home\index

When I open it I keep getting: Routing Error No route matches "/"

Hey, I’m trying to sort out the routing still, I’ve generated a home

controller, deleted the public/index.html and changed the routes.rb to

have :root to=> “home#index” and I have changed the html code in

app\view\home\index

When I open it I keep getting: Routing Error No route matches “/”

Hmmm it sounds like you might be getting sent elsewhere. Is there anotehr :root entry in your routes? As well, do you have both an home/index.html.erb view as well as an index action in your controller? Also, is there any other code you have added to the app such as in the application controller which might be redirecting you?

Hey, I'm trying to sort out the routing still, I've generated a home
controller, deleted the public/index.html and changed the routes.rb to
have :root to=> "home#index" and I have changed the html code in
app\view\home\index

It should just be root, not :root so
root :to => "home#index"

Colin

David Kahn wrote in post #997316:

It is nothing to do with the controller, it is saying there is no
route. That is before it even looks for a controller. Did you try
root :to =>
instead of
:root to =>
as I suggested? Don't forget to restart the server after changing
routes.rb. It is interpreted when the app is first loaded.
If it is still not working post your routes.rb file here.

Colin

Yeah I had changed to root :to=> and restarted the server.

Ok, my routes.rb=

Debate::Application.routes.draw do
  resources :posts

  get "home/index"

  # The priority is based upon order of creation:
  # first created -> highest priority.

  # Sample of regular route:
  # match 'products/:id' => 'catalog#view'
  # Keep in mind you can assign values other than :controller and
:action

  # Sample of named route:
  # match 'products/:id/purchase' => 'catalog#purchase', :as =>
:purchase
  # This route can be invoked with purchase_url(:id => product.id)

  # Sample resource route (maps HTTP verbs to controller actions
automatically):
  # resources :products

  # Sample resource route with options:
  # resources :products do
  # member do
  # get 'short'
  # post 'toggle'
  # end

Yeah I had changed to root :to=> and restarted the server.

Ok, my routes.rb=

Debate::Application.routes.draw do
resources :posts
...
# You can have the root of your site routed with "root"
# just remember to delete public/index.html.
# root :to => "home#index"

Unfortunately you have it commented out. Remove the #

# See how all your routes lay out with "rake routes"

Take note of this. You can run
rake routes
to see what routes you have defined.

Colin

That's ok, don't mention it. Oh you didn't, never mind.

Colin

it worked ofcourse. Thanks again.