Capistrano/Webistrano SSH Auth failure


Recently, I setup Webistrano to help manage our Rails application
projects and deployments. I'm running into some problems deploying to
our web/app & db hosts. We have restricted sshd (for corporate
security policy reasons) to use private/public key-based authenticaton
rather than using password authentication. I have an id_dsa in my
"runner" user's .ssh directory and Webistrano configured appropriately
for the ssh_keys parameter equal to /home/user/.ssh/id_dsa. I've also
tried using id_rsa keys as well and get same result.

The error that Webistrano sends as a result of the deploy:setup task
is as follows:

*** SSH options: setting ssh_keys to: /home/user/.ssh/id_dsa
  * executing `deploy:setup'
  * executing "umask 02 && mkdir -p /webapps/asset_management /webapps/
asset_management/releases /webapps/asset_management/shared /webapps/
asset_management/shared/system /webapps/asset_management/shared/log /
    servers: ["dbserverIP", "webappserverIP"]
*** connection failed for: webappserverIP
(Net::SSH::AuthenticationFailed: deployment_user(SSH login)),
dbserverIP (Net::SSH::AuthenticationFailed: deployment_user(SSH

Thanks in advance as I'm searching this Group and other online Rails
forums and haven't yet come up with a solution. My thinking being
Webistrano is such a new solution for managing Rails app deployment,
nobody out there has come across this or written up anything. Any
advice from anyone out there in the Rails community would be greatly
appreciated. :slight_smile:


Haven't tried this with Webistrano but i guess the config will be

My deploy.rb for my production site using Capistrano has the

default_run_options[:pty] = true
ssh_options[:username] = "myusername"
ssh_options[:host_key] = "ssh-rsa"
ssh_options[:port] = 22

The top line is the one that makes it work for me. I don't claim to
understand why by Jamis Buck recommended it!

Hope that helps,