Can't run rake with rails3.0.0beta4- problem with bundler, i think....

Hello,

Anyone else running into this same problem? I've come across some
posts on the subject, but none have helped

Installed:
rails 3.0.0beta4
bundler 0.9.26
ruby 1.9.1
rake 0.8.7

After creating an initial rails app, then attempting to run the
migration i get this

rake db:migrate
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:32: warning: already initialized constant RAKEVERSION

/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/alt_system.rb:
32: warning: already initialized constant WINDOWS
WARNING: Possible conflict with Rake extension: String#ext already
exists
WARNING: Possible conflict with Rake extension: String#pathmap already
exists
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:404:
warning: already initialized constant EMPTY_TASK_ARGS
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:452:
warning: already initialized constant EMPTY
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:960:
warning: already initialized constant RUBY_EXT
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:964:
warning: already initialized constant RUBY
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1033:
warning: already initialized constant LN_SUPPORTED
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1242:
warning: already initialized constant ARRAY_METHODS
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1245:
warning: already initialized constant MUST_DEFINE
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1249:
warning: already initialized constant MUST_NOT_DEFINE
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1253:
warning: already initialized constant SPECIAL_RETURN
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1259:
warning: already initialized constant DELEGATING_METHODS
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1569:
warning: already initialized constant DEFAULT_IGNORE_PATTERNS
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1575:
warning: already initialized constant DEFAULT_IGNORE_PROCS
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1612:
warning: already initialized constant FileList
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1638:
warning: already initialized constant EARLY
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1968:
warning: already initialized constant DEFAULT_RAKEFILES
rake aborted!
stack level too deep
/home/dave/dev/rails/wmc/Rakefile:7:in `<top (required)>'

In some other post, there have been some people saying this is because
bundler and rake aren't playing well together, and you'll have to 'gem
install' all the gems you want manually. I really don't want to mess
around with that - i just want bundler to work!! Anyone have any
answers for this problem? thanks in advance

Dave