Can't able to debug my application

Hi,

I am not able to debug my *.html.erb file in ruby. The breakpoints
leaves when debugging?. Can anybody help me why i can't do?

Regards,
Periyasamy.R

Sorry I do not understand exactly the problem you are seeing. Are you
able to break in the controller by entering a line
debugger

If so then you should be able to break into the erb file with
<% debugger %>

If neither work then have you installed ruby-debug?

Colin

Colin Law wrote:

Hi,

I am not able to debug my *.html.erb file in ruby. The breakpoints
leaves when debugging?. Can anybody help me why i can't do?

Sorry I do not understand exactly the problem you are seeing. Are you
able to break in the controller by entering a line
debugger

If so then you should be able to break into the erb file with
<% debugger %>

If neither work then have you installed ruby-debug?

Colin

Hi,

Thanks for your reply. I can able to do in controller as well as in
model. But in .html.erb file i can't able to debug all the statements.
Some lines only getting debugging. I also have the gem
ruby-debug-base (0.10.3, 0.10.2)
ruby-debug-ide (0.4.9, 0.3.1).

But no solution.

Thanks,

Periyasamy.

Can you post the erb code around a debugger statement that is not working?
Are you certain that execution is getting to the debugger statement?

Colin

Colin Law wrote:

[...]
Thanks for your reply. I can able to do in controller as well as in
model. But in .html.erb file i can't able to debug all the statements.
Some lines only getting debugging. I also have the gem
ruby-debug-base (0.10.3, 0.10.2)
ruby-debug-ide (0.4.9, 0.3.1).

Can you post the erb code around a debugger statement that is not
working?
Are you certain that execution is getting to the debugger statement?

Colin

Hi,

FYI.

The below lines are getting debugged,

<%=h "Test Report " + rcnt.to_s %> </h4> <br/>
<%=h "Test - " + @tstarttime %> <br/>

But the below lines are not getting debugging,

<% @tsteps = TstInstance.get_tstnames_by_tsttype(@tstarttime) %>
    <% for rows_steps in @tsteps %>
        <% stepname = rows_steps["steps_name"] %>
        <% @steptime = rows_steps["steptime"] %>
     <%end%>

I can't see the debugging in the iteration even if i break point for
each line.

Thanks,
Periyasamy.R

I still don't understand exactly what you mean. Describe exactly what
you are doing and what happens. I do not see a breakpoint in your
code.

Colin