Bundle Install issue

Hi all,

Sorry for the long rambling post, but I thought it would be best to
list my GEMS and Gemfile here as well.

I have got myself a new laptop that is running unbuntu 10.4 and I am
porting my code from a ubuntu 9.10 which was working fine.

I have installed RVM and Ruby 1.9.1 on my new laptop which is a 64bit
Core2 Duo the old machine was 32bit

=> ruby-1.9.1-p378 [ x86_64 ]

I have moved my development directory over to my new pc which was
developed under rails 3 beta3.

I have the following gems installed.

*** LOCAL GEMS ***

abstract (1.0.0)
actionmailer (3.0.0.rc, 3.0.0.beta3)
actionpack (3.0.0.rc, 3.0.0.beta3)
activemodel (3.0.0.rc, 3.0.0.beta3)
activerecord (3.0.0.rc, 3.0.0.beta3)
activeresource (3.0.0.rc, 3.0.0.beta3)
activesupport (3.0.0.rc, 3.0.0.beta3, 2.3.8)
arel (0.4.0, 0.3.3)
builder (2.1.2)
bundler (1.0.0.rc.3, 0.9.26)
dbi (0.4.5)
deprecated (2.0.1)
erubis (2.6.6)
geokit (1.5.0)
hpricot (0.8.2)
i18n (0.4.1, 0.3.7)
json (1.4.3)
json_pure (1.4.3)
mail (2.2.5)
memcache-client (1.8.5)
mime-types (1.16)
mysql (2.8.1)
nokogiri (1.4.3.1)
nokogirl (1.0)
paperclip (2.3.3)
polyglot (0.3.1)
rack (1.2.1, 1.1.0)
rack-mount (0.6.9)
rack-test (0.5.4)
rails (3.0.0.rc, 3.0.0.beta3)
railties (3.0.0.rc, 3.0.0.beta3)
rake (0.8.7)
RedCloth (4.2.3)
rmagick (2.13.1)
rubygems-update (1.3.7)
sqlite3-ruby (1.3.1)
text-format (1.0.0)
text-hyphen (1.0.0)
thor (0.14.0, 0.13.8)
treetop (1.4.8)
tzinfo (0.3.22)
unicorn (1.1.2)

I have then tried to get bundler to install from the Gemfile

source 'http://rubygems.org'

gem 'rails', '3.0.0.beta3'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'mysql'

gem 'paperclip', :git => 'git://github.com/thoughtbot/
paperclip.git', :branch => "rails3"

gem 'geokit'

gem "will_paginate", :git => "git://github.com/mislav/
will_paginate.git", :branch => "rails3"

#gem ‘searchlogic’
#gem ‘meta_search’, :git => ‘http://github.com/ernie/meta_search.git

# Use unicorn as the web server
# gem 'unicorn'

# Deploy with Capistrano
# gem 'capistrano'

# Bundle the extra gems:
# gem 'bj'
# gem 'nokogiri', '1.4.1'
# gem 'sqlite3-ruby', :require => 'sqlite3'
# gem 'aws-s3', :require => 'aws/s3'

# Bundle gems for certain environments:
# gem 'rspec', :group => :test
# group :test do
# gem 'webrat'
# end

I used the following command which worked ok on the old laptop (tested
again while writing this message). But on my new pc it fails with the
error below.

huet@ubuntu:~/projects/admin_console$ bundle install

Updating git://github.com/thoughtbot/paperclip.git
fatal: ambiguous argument 'rails3': unknown revision or path not in
the working tree.
Use '--' to separate paths from revisions
An error has occurred in git when running `git rev-parse rails3.
Cannot complete bundling.
huet@ubuntu:~/projects/admin_console$

Can anyone help, I have searched for the error on google, but it does
not turn up any fixes.

Thank you in advance

Huet

Huet wrote:

gem 'paperclip', :git => 'git://github.com/thoughtbot/
paperclip.git', :branch => "rails3"

There's no "rails3" branch in paperclip anymore, that's what the error
is about.

Agnieszka