bad to still start a 2.x app?

Hi,

I am still quite new to rails and now I have to do a project for a
client. She has her hosting a hostgator and they use cpanel as admin
panel.
The problem is that cpanel is not compatible with rails 3, the actual
installed version there is 2.3.5
Is it a bad idea to still start a 2.3.x application or is it "nearly
the same"...
like more a problem in my head than it really is...
meaning should i try to find a workaround to get v 3.x running or just
learn 2.3 as well...?

thanks for your opinions

I would recommend to try to find a work around, specially because you will be starting a new project, the rails community is quickly migrating gems/plugins to rails 3 and pretty soon new gems will not offer backward compatibility.

Explore the options with the hosting provider.

Good luck!

Why don't you try other hosting services like heroku.com and
hostingrails.com

I think hostingrails.com is currently rates #1 ruby hosting service in
blogs I read.

I believe 2.3.5 has some serious security issues. It should at least
be upgraded to 2.3.latest. The fact that the hoster has not made at
least the latest 2.3 available suggests they are not serious about
Rails. Better to move to one that is, heroku for example.

Colin

the problem is that the client made already a 3-year-payment for this
hoster :-/
in general the hoster looks great, it is just this issue with rails3
not being supported yet..
but i think i can upgrade to at least 2.3.8, like colin pointed out.

the problem is that the client made already a 3-year-payment for this
hoster :-/
in general the hoster looks great, it is just this issue with rails3
not being supported yet..
but i think i can upgrade to at least 2.3.8, like colin pointed out.

You want the latest, is it 2.3.11? There was a recent security fix.

Colin

I was running 2.3.8, but one thing that sucks about using 2.3.8 is that
I cannot write sophisticated using RSpec2. Which is why I am migrating
to 3.0.4.

So, if you would like to have good unit tests (using RSpec2), I would
recommend moving to Rails 3.

Best,
Radhesh