Which is the best ruby version for OS X lion?

I just want to know if someone can tell which ruby version is the most
compatible with MAC OS X 10.7. Ruby 1.9.2 just blows up everywhere ,
yard blows up , pg just crashes with no feedback, is a mess. Can
someone tell me what can i do before trying to downgrade.

Simple: never use the first release of anything.

I just want to know if someone can tell which ruby version is the most

compatible with MAC OS X 10.7. Ruby 1.9.2 just blows up everywhere ,

yard blows up , pg just crashes with no feedback, is a mess. Can

someone tell me what can i do before trying to downgrade.

I have been using Ruby 1.9.2 with Mac OS 10.7 for several months now with any

issues. What version of Rails are you having these issues? Also, what’s the error

message(s) you’re seeing with Yard? Does PG work without Yard? If this is the

case, I would recommend filing a ticket against the Yard project, http://yardoc.org/.

Good luck,

-Conrad

I haven't had any issues with 1.9.2 (installed via rvm)
One possible source of problems is when (especially if you use
macports) applications or libraries are built against one version of a
library, but end up running against another.

Fred