Where db tasks in Rails 4.0.0.beta

Hi,

Maybe, my question is idiot but when create new application with rails-4.0.0.beta and I run rake -T, the output doesn’t display database tasks.

rake about # List versions of all Rails frameworks and the environment

rake assets:clean # Remove compiled assets

rake assets:precompile # Compile all the assets named in config.assets.precompile

rake doc:app # Generate docs for the app – also available doc:rails, doc:guides (options: TEMPLATE=/rdoc-template.rb, TITLE="C…

rake log:clear # Truncates all *.log files in log/ to zero bytes

rake middleware # Prints out your Rack middleware stack

rake notes # Enumerate all annotations (use notes:optimize, :fixme, :todo for focus)

rake notes:custom # Enumerate a custom annotation, specify with ANNOTATION=CUSTOM

rake rails:template # Applies the template supplied by LOCATION=(/path/to/template) or URL

rake rails:update # Update configs and some other initially generated files (or use just update:configs, update:scripts, or update:a…

rake routes # Print out all defined routes in match order, with names.

rake secret # Generate a cryptographically secure secret key (this is typically used to generate a secret for cookie sessions).

rake stats # Report code statistics (KLOCs, etc) from the application

rake test # Runs test:units, test:functionals, test:integration together (also available: test:benchmark, test:profile)

rake test:recent # Run tests for {:recent=>“test:prepare”} / Test recent changes

rake test:single # Run tests for {:single=>“test:prepare”}

rake test:uncommitted # Run tests for {:uncommitted=>“test:prepare”} / Test changes since last checkin (only Subversion and Git)

rake time:zones:all # Displays all time zones, also available: time:zones:us, time:zones:local – filter with OFFSET parameter, e.g., …

rake tmp:clear # Clear session, cache, and socket files from tmp/ (narrow w/ tmp:sessions:clear, tmp:cache:clear, tmp:sockets:clear)

rake tmp:create # Creates tmp directories for sessions, cache, sockets, and pids

How can I run the db tasks ?

Your faithfully.

Everything work fine to me https://gist.github.com/3776317

Rafael Mendonça França
http://twitter.com/rafaelfranca

https://github.com/rafaelfranca

Hi,

Excuse me, I have installed again Rails 4 and db tasks are back…

Thanks.