what a disappointing evening!

hey guys.. I've been struggling trying to install rails_admin for the
whole evening and I'm now considering killing myself instead :frowning:
my Gemfile are like this (copied from my original rails directory, with
rail_admin git added):

==============================================

but I continuously ran into this problem: after “bundle install”

Bundler could not find compatible versions for gem “jquery-rails”:

In Gemfile:

rails_admin (>= 0) ruby depends on

  jquery-rails (~> 1.0.17) ruby



jquery-rails (1.0.16)

================

but I have already got jquery-rails 1.0.17 installed. I’ve run

 grep "jquery-rails" /home/xxx/.rvm/gems/ruby-1.9.2-p290/ -r

in my computer and I didn’t find any where required 1.0.17. So I got

very confused :frowning:

As you mentioned, it seems that rails_admin needs jquery-rails 1.0.17 and you are installing only 1.0.16… you may try just jquery-rails without the version and it may work

hey guys.. I've been struggling trying to install rails_admin for the
whole evening and I'm now considering killing myself instead :frowning:
my Gemfile are like this (copied from my original rails directory, with
rail_admin git added):

source 'http://rubygems.org'
gem 'rails', '3.1.1'
gem 'sqlite3'
gem 'rails_admin', :git => 'git://github.com/sferik/rails_admin.git'
group :assets do
gem 'sass-rails', '~> 3.1.4'
gem 'coffee-rails', '~> 3.1.1'
gem 'uglifier', '>= 1.0.3'
end
gem 'jquery-rails', '~> 1.0.16'

You are specifically asking for 1.0.16 here, change it to 17 or
possibly remove the number entirely.

Colin

Not exactly. The '~>' version predicate is like shorthand:

  '~> 1.0.16'
is equivalent to
  '>= 1.0.16', '< 1.1'

When you add that to '~> 1.0.17', you end up with:
  '>= 1.0.17', '< 1.1'

So jquery-rails 1.0.17 should be OK.

Perhaps you need to do:

  bundle update jquery-rails

To allow a version different than 1.0.16 to be installed which is consistent with all the constraints.

-Rob

Rob Biedenharn
Rob@AgileConsultingLLC.com http://AgileConsultingLLC.com/
rab@GaslightSoftware.com http://GaslightSoftware.com/

thank you guys! I've solved this problem :slight_smile:
first I run
    bundle update jquery-rails
but it only get me to version 1.0.16. So I went to their homepage and
download 1.0.17 myself. then I uninstalled version 1.0.16, replaced it
with version 1.0.17. all of a sudden, "bundle install" was ok! thank
you for all the helping!
And special thanks to Rob. I've never understand the "~>" until your
post :slight_smile: